Download

Download the app and install to get started.
For Users
For Servers

The Remote Access Client allows users to log in and join the VPN from their workstations and phones

Windows
macOS
Linux
Android
IOS

The Netclient is installed on devices and servers and runs as a background agent that manages peer-to-peer VPN connections. It's always-on and can be set as a gateway by administrators.

Windows
macOS
Linux
Docker
Any Other Device
Routers
Select your version:
Download
Download Remote Access Client for Windows
Select your version:
Download
Download Netclient for Windows
Select your version
Select your version
Download Remote Access Client for Mac OS
Select your version
Select your version
Download Netclient  for Mac OS
curl -sL 'https://apt.netmaker.org/remote-client/gpg.key' | sudo tee /etc/apt/trusted.gpg.d/remote-client.asccurl -sL 'https://apt.netmaker.org/remote-client/debian.deb.txt' | sudo tee /etc/apt/sources.list.d/remote-client.listsudo apt updatesudo apt search remote-client  # to see available versionssudo apt install remote-client
📋
Select your version:
wget -O netclient https://fileserver.netmaker.io/releases/download/latest/netclient-linux-amd64 && chmod +x ./netclient && sudo ./netclient install
📋
wget -O netclient https://fileserver.netmaker.io/releases/download/latest/netclient-linux-arm64 && chmod +x ./netclient && sudo ./netclient install
📋
wget -O netclient https://fileserver.netmaker.io/releases/download/latest/netclient-linux-armv7 && chmod +x ./netclient && sudo ./netclient install
📋
wget -O netclient https://fileserver.netmaker.io/releases/download/latest/netclient-linux-armv6 && chmod +x ./netclient && sudo ./netclient install
📋
wget -O netclient https://fileserver.netmaker.io/releases/download/latest/netclient-linux-armv5 && chmod +x ./netclient && sudo ./netclient install
📋
wget -O netclient https://fileserver.netmaker.io/releases/download/latest/netclient-linux-mips-hardfloat && chmod +x ./netclient && sudo ./netclient install
📋
wget -O netclient https://fileserver.netmaker.io/releases/download/latest/netclient-linux-mips-softfloat && chmod +x ./netclient && sudo ./netclient install
📋
wget -O netclient https://fileserver.netmaker.io/releases/download/latest/netclient-linux-mipsle-hardfloat && chmod +x ./netclient && sudo ./netclient install
📋
wget -O netclient https://fileserver.netmaker.io/releases/download/latest/netclient-linux-mipsle-softfloat && chmod +x ./netclient && sudo ./netclient install
📋
Download Remote Access Client for Android
Download Remote Access Client for IOS
Download
Select your version:

Docker
Run sudo docker run -d --network host --privileged -e TOKEN={ENROLLMENT_KEY} -v /etc/netclient:/etc/netclient --name netclient gravitl/netclient:latest

Docker Compose

services:
  netclient:
    image: gravitl/netclient: latest
    network_mode: host
    privileged: true
    environment:
      - TOKEN={ENROLLMENT_KEY}
    volumes:
      - /etc/netclient:/etc/netclient
📋
Any Other Device
Routers
Thank you! Your submission has been received!
Oops! Something went wrong while submitting the form.

Install Netclient on Windows

Netclient is responsible for connecting individual nodes to the Netmaker network. It handles the configuration and management of WireGuard on each node.

Install Netclient on Mac

Netclient is responsible for connecting individual nodes to the Netmaker network. It handles the configuration and management of WireGuard on each node.
Brew Install
brew tap gravitl/netclient
(optional) brew audit netclient
brew install netclient

Install Netclient on Linux

Debian Distros (debian/ubuntu/mint/pop-os)
curl -sL 'https://apt.netmaker.org/gpg.key' | sudo gpg --dearmor -o /usr/share/keyrings/netmaker-keyring.gpg
echo "deb [signed-by=/usr/share/keyrings/netmaker-keyring.gpg] https://apt.netmaker.org stable main" | sudo tee /etc/apt/sources.list.d/netclient.list
sudo apt update
sudo apt install netclient
Red Hat Distros (fedora/redhat/centos/rocky)
curl -sL 'https://rpm.netmaker.org/gpg.key' | sudo tee /tmp/gpg.key
curl -sL 'https://rpm.netmaker.org/netclient-repo' | sudo tee /etc/yum.repos.d/netclient.repo
sudo rpm --import /tmp/gpg.key
sudo dnf check-update
sudo dnf install netclient
Arch Distros (arch/manjaro/endeavouros)
yay -S netclient
OpenSUSE (tumbleweed/leap)
sudo rpm --import https://rpm.netmaker.org/gpg.key
curl -sL 'https://rpm.netmaker.org/netclient-repo' | sudo tee /etc/zypp/repos.d/netclient.repo
sudo zypper refresh
sudo zypper install netclient
Deploy Netclient using Docker
Docker
sudo docker run -d --network host --privileged -e
TOKEN={ENROLLMENT_KEY} -v /etc/netclient:/etc/netclient --name netclient gravitl/netclient:v0.24.1

Docker Compose
Docker Compose
services:  
netclient:    
image: gravitl/netclient:v0.24.1    
network_mode: host    
privileged: true    
environment:
TOKEN={ENROLLMENT_KEY}
volumes: - /etc/netclient:/etc/netclient
Install Netmaker on Any Other Device
Steps to join a network:Any device that supports WireGuard can be integrated into your network using a Client Config file with the Remote Access Gateway. Follow this guide to set up the Remote Access Gateway and generate a Client Config file for your device, which can be run with WireGuard. - https://docs.netmaker.io/external-clients.html#remote-access
Install Netmaker on a Router

Netmaker allows you to generate and manage your VPN configuration files. You can get the WireGuard VPN configuration by following these steps:

  1. Navigate to your network's Remote Access tab. You should see:
    • The Gateways table on the left-hand side
    • The VPN Config Files table on the right-hand side of the page
  2. If you have multiple gateways, select the specific one by clicking on it (if it hasn't been selected already).
  3. If necessary, find the VPN configuration by inputting its name in the Search box.
  4. Once you've located the configuration file, hover over or click on its 'kebab' icon in the right-hand corner of the row. A context menu should appear.
Get Client Config

In the context menu, you have two options:

  1. Click on 'View Config' to view and copy the configuration file.
  2. Click on 'Download' to get a copy of the configuration file.
Sample Client Config

Using the Configuration

Once you have the configuration information or the configuration file, you can apply it to your router:

1. pfSense

This guide will help you set up WireGuard on pfSense 2.7.2. We will connect to a Netmaker network via a Remote Access Gateway.

  1. Install WireGuard using the Package Manager in System -> Package Manager -> Available Packages
  2. Go to VPN -> WireGuard -> Tunnels, and create a new WireGuard tunnel using the configuration information provided by Netmaker. Click on the Generate button under the Interface Keys fields before pasting the Private Key (from the configuration file generated by Netmaker). Save or submit the form and take note of the tunnel interface name.
  3. Go to VPN -> WireGuard -> Peers, and create a peer. Input the necessary configuration information.
  4. Enable WireGuard in VPN -> WireGuard -> Settings, and click on the Apply Changes button. Ensure that the 'handshake' icon is green under the Status tab before proceeding.
  5. Go to Interfaces -> Assignments, and assign or add a new interface for the WireGuard tunnel you created in Step 2. Take note of the interface name (e.g., OPT1).
  6. Go to Interfaces -> [OPT1], tick the 'Enable interface' checkbox, input the MTU, static IP address, and the Netmaker network prefix.
  7. If connecting to a Netmaker Internet Gateway, click on the 'Add a new gateway' button. Depending on your use case, you may tick the Default Gateway checkbox.
  8. Create a Firewall rule allowing traffic from the Netmaker network to the target resource. Go to Firewall -> Rules -> [OPT1] and add a rule as needed.

2. OPNsense

This guide will help you set up WireGuard on OPNsense 24.1_1. We will connect to a Netmaker network via a Remote Access Gateway.

  1. WireGuard comes pre-installed on OPNsense 24.1_1. For OPNsense 23.7.12 and below, install WireGuard as a plug-in in System -> Firmware -> Plugins.
  2. Go to VPN -> WireGuard -> Settings -> Instances, and create a new WireGuard tunnel instance using the configuration information provided by Netmaker.
  3. Go to VPN -> WireGuard -> Settings -> Peers, and create a WireGuard peer using the information provided by Netmaker.
  4. Enable WireGuard in VPN -> WireGuard -> Settings -> General. Click on the Apply Changes button.
  5. Go to Interfaces -> Assignments, and assign or add a new interface for the WireGuard tunnel.
  6. Go to Interfaces -> [OPT1], and tick the 'Enable interface' and the 'Prevent interface removal' checkboxes.
  7. Create a route to the Netmaker network by first creating a gateway. Go to System -> Gateways -> Configuration, then add a new gateway.
  8. Add the necessary routing entry. Go to System -> Routes -> Configuration, then add a route to the Netmaker network via the gateway created in the previous step.
  9. Create a Firewall rule for WireGuard allowing traffic between it and the target resource.

3. MikroTik

This guide will help you set up WireGuard on MikroTik 7.13.3. We will connect to a Netmaker network via a Remote Access Gateway.

  1. WireGuard comes pre-installed on MikroTik 7.13.3.
  2. Use the following commands in MikroTik's CLI to configure WireGuard:
  3. Copy
  4. /interface/wireguard
    add name=wg-netmaker mtu=1420 private-key="iMfHqGANXMJHGMBKwuo89txiU3/9edC20TxWpFtmU2Y="

    /interface/wireguard/peers
    add allowed-address=10.40.70.0/24 endpoint-address=188.166.235.45 endpoint-port=51821 interface=wg-netmaker public-key="GM80g/eeXgkOrk0yYtdhhU73ETHffpojG2Ewd+N4kXI=" persistent-keepalive=20 client-dns=159.159.159.159

    /ip/address
    add address=10.40.70.254/32 interface=wg-netmaker

    /ip/route
    add dst-address=10.40.70.0/24 gateway=wg-netmaker

4. OpenWrt

This guide will help you set up WireGuard on OpenWrt 23.05.2. We will connect to a Netmaker network via a Remote Access Gateway.

  1. Go to System -> Software. Click on the Update lists… button then search for WireGuard. Install WireGuard-tools and luci-proto-WireGuard (for Web GUI). Reboot.
  2. Go to Network -> Interfaces, and add a new WireGuard tunnel interface.
  3. Click on Load Configuration…, paste the WireGuard configuration and click Import settings.
  4. Go to the Peers tab. Edit the generated peer, tick the Route Allowed IPs field. Save and apply the changes.
  5. Go to Status -> WireGuard and make sure that a handshake has taken place.
  6. Go to Network -> Firewall, and add a zone allowing traffic between the WireGuard tunnel and the LAN.

5. Other routers

Please refer to these links for instructions on how to configure WireGuard:

Install Remote Access Client on Windows

The Remote Access Client (RAC) is best suited for non-admin users who want to gain remote access to the network, this also provides admins fine-grained control over users in the network by attaching/removing them from a remote access gateway.

Admins can also use RAC to gain remote access to the network with a different machine.


Install Remote Access Client on Mac

The Remote Access Client (RAC) is best suited for non-admin users who want to gain remote access to the network, this also provides admins fine-grained control over users in the network by attaching/removing them from a remote access gateway.

Admins can also use RAC to gain remote access to the network with a different machine.


Install Remote Access Client on Linux

Red Hat Distros (fedora/redhat/centos/rocky)
curl -sL 'https://apt.netmaker.org/remote-client/gpg.key' | sudo tee /etc/apt/trusted.gpg.d/remote-client.asc
curl -sL 'https://apt.netmaker.org/remote-client/debian.deb.txt' | sudo tee /etc/apt/sources.list.d/remote-client.list
sudo apt update
sudo apt search remote-client  # to see available versions
sudo apt install remote-client

Following the above instructions, you can run RAC from your Linux desktop environment launcher or from the command line using the remote-client command.
Install Netmaker on Android
The Remote Access Client (RAC) is best suited for non-admin users who want to gain remote access to the network, this also provides admins fine-grained control over users in the network by attaching/removing them from a remote access gateway.

Admins can also use RAC to gain remote access to the network with a different machine.


  • Download and open the Netmaker Android app
  • Accept the prompts to install a VPN configuration and allow push notifications
  • Sign up using your team's email address
Install Netmaker on iOS
The Remote Access Client (RAC) is best suited for non-admin users who want to gain remote access to the network, this also provides admins fine-grained control over users in the network by attaching/removing them from a remote access gateway.

Admins can also use RAC to gain remote access to the network with a different machine.


  • Download and open the Netmaker iOS app
  • Accept the prompts to install a VPN configuration and allow push notifications
  • Sign up using your team's email address
Star us on GitHub
Can we use Cookies?  (see  Privacy Policy).